.RU

Практический пример работы с BGP-сетью - Протокол обмена управляющими сообщениями icmp. Протоколы обмена маршрутной информацией

Практический пример работы с

BGP

-сетью


Имеем следующую BGP-сеть


Рисунок 6.

Если AS связана с двумя ISP через EBGP, IBGP должен использоваться между роутерами внутри данной AS для лучшего управления маршрутами.

Рассмотрим AS100, имеющую два EBGP соединения (роутеры «A» и «B») с внешним миром (роутеры «C» и «D»). «A» и «B» общаются между собой по IBGP.

Между роутерами «A-F», «A-B» и «B-F» этой AS также используется OSPF (протокол семейства IGP).

Приведенная ниже конфигурация роутеров – предварительная, поскольку она не полная. Это сделано для того, чтобы продемонстрировать методы BGP исправления ошибок.

! Router A



hostname RouterA



!



interface loopback 0



ip address 203.250.13.41 255.255.255.0



!



interface ethernet 0



ip address 203.250.14.1 255.255.255.0



!



interface serial 0



ip address 128.213.63.1 255.255.255.252



!



router ospf 10



network 203.250.0.0 0.0.255.255 area 0



router bgp 100



network 203.250.13.0 mask 255.255.255.0



network 203.250.14.0 mask 255.255.255.0



neighbor 128.213.63.2 update-source loopback 0



! Router B



!



hostname RouterB



!



interface serial 0



ip address 203.250.15.2 255.255.255.252



!



inetrface serial 1



ip address 192.208.10.6 255.255.255.252



!



router ospf 10



network 203.250.0.0 0.0.255.255 area 0



!



router bgp 100



network 203.250.15.0



neighbor 192.208.10.5 remote-as 300



neighbor 203.250.15.1 remote-as 100



! Router C



hostname RouterC



!



interface loopback 0



ip address 128.213.63.130 255.255.255.192



!



interface serial 2/0



ip address 128.213.63.5 255.255.255.252



!



interface serial 2/1



ip address 128.213.63.2 255.255.255.252



!



router bgp 200



network 128.213.0.0



neighbor 128.213.63.1 remote-as 100



neighbor 128.213.63.6 remote-as 400



! Router D



hostname RouterD



!



interface loopback 0



ip address 192.208.10.174 255.255.255.192



!



interface serial 0/0



ip address 192.208.10.5 255.255.255.252



!



interface serail 0/1 (ERROR: здесь и строчка ниже в оригинале – с опечаткой)



ip address 192.208.10.2 255.255.255.252



!



router bgp 300



network 192.208.10.0



neighbor 192.208.10.1 remote-as 500



neighbor 192.208.10.6 remote-as 100



! Router E



hostname RouterE



!



interface loopback 0



ip address 200.200.10.1 255.255.255.0



!



interface serial 0



ip address 195.211.10.2 255.255.255.252



!



interface serial 1



ip address 128.213.63.6 255.255.255.252



!



router bgp 400



network 200.200.10.0



neighbor 128.213.63.5 remote-as 200



neighbor 195.211.10.1 remote-as 500



! Router F



!



hostname RouterF



!



interface ethernet 0



ip address 203.250.14.2 255.255.255.0



!



interface serial 1



ip address 203.250.15.1 255.255.255.252



!



router ospf 10



network 203.250.0.0 0.0.255.255 area 0



! Router G



hostname RouterG



!



interface loopback 0



ip address 195.211.10.174 255.255.255.192



!



interface serial 0



ip address 192.208.10.0 255.255.255.252



!



interface serial 1



ip address 195.211.10.1 255.255.255.252



!



router bgp 500



network 195.211.10.0



neighbor 192.208.10.2 remote-as 300



neighbor 195.211.10.2 remote-as 400


Определение состояния

BGP


Предположим, что (см. рисунок 6) связь между роутерами «B» и «D» испортилась. Выполним на роутере «B» команду show ip bgp:

RouterB

#

show

ip

bgp



table version is 4, local router ID is 203.250.15.2



Status codes: s suppesed, d damped, h history, * valid, > best, i internal



Origin codes: i – IGP, e – EGP,? – incomplete



Network Next Hop Metric LocPrf Weight Path



*i128.213.0.0 128.213.63.2 0 100 0 200 i



*i192.208.10.0 128.213.63.2 100 0 200 400 500 300 i



*i195.211.10.0 128.213.63.2 100 0 200 400 500 i



*i200.200.10.0 128.213.63.2 100 0 200 400 i



*>i203.250.13.0 203.250.13.41 0 100 0 i



*>i203.250.14.0 203.250.13.41 0 100 0 i



*> 203.250.15.0 0.0.0.0 0 32768 i



Символ «i» в начале строки означает, что о данном маршруте стало известно от IBGP peer'а.

Символ «i» в конце строки означает, что информация о данном пути пришла от IGP.

Первая строка читается так:

Информация о доступности сети 128.213.0.0 получена через AS_path 200, и для того, чтобы с данного роутера достичь этой сети, в качестве Next hop'а следует использовать 128.213.63.2.

Замечание: любой маршрут, который сгенерирован на данном роутере (см. 203.250.15.0) имеет next hop = 0.0.0.0.

Символ «>» означает, что BGP выбрал данный маршрут, как лучший. Процесс выбора наилучшего маршрута описан выше в главе «Summary of the BGP Path Selection Process». BGP всегда выбирает только один маршрут, как лучший. После чего он записывает этот маршрут в IP routong table и анонсирует этот путь другим BGP peer'ам.

Заметим, что next hop attribute 128.213.63.2, имеющий место для части маршрутов, унаследован от EBGP.

Теперь проверим IP routing table на роутере «B»:

RouterB# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate



default



Gateway of last resort not set



203.250.13.0 255.255.255.255 is subnetted, 1 subnets



O 203.250.13.41 [110/75] via 203.250.15.1, 02:50:45, Serial0



203.250.15.0 255.255.255.252 is subnetted, 1 subnets



C 203.250.15.0 is directly connected, Serial0



O 203.250.14.0 [110/74] via 203.250.15.1, 02:40:46, Serial0



Заметим, что ни один BGP маршрут не появился в IP routing table. Это произошло потому, что в данной конфигурации мы имеем одну проблему: маршруты к некоторым сетям, содержащиеся в BGP route table на «B», имеют next hop = 128.213.63.2, который недоступен с «B».

Адрес 128.213.63.2 недоступен потому, что в таблице маршрутизации на «B» отсутствует запись о том, как достичь данный адрес через IGP (в данном случае, через OSPF). Итак, роутер «B» не знает о 128.213.63.0 из OSPF.

Исправление проблемы

Next

Hop


В данном примере проблема с next hop может быть решена двумя способами:

*

Использованием на роутере «A» команды «next-hop-self» для изменения значения next hop между роутерами «A» и «B».

*

На роутере «A» настроить OSPF _на интерфейсе_ Serial 0, указав его как passive. В этом случае роутер «B» будет знать, каким образом достичь next hop 128.213.63.2.

Итак, следующая конфигурация роутера «A» устанавливает OSPF на Serial 0 и делает его passive:

! Router A



hostname RouterA



!



interface loopback 0



ip address 203.250.13.41 255.255.255.0



!



interface ethernet 0



ip address 203.250.14.1 255.255.255.0



!



interface serial 0



ip address 128.213.63.1 255.255.255.252



!



router ospf 10



passive-interface serial 0



network 203.250.0.0 0.0.255.255 area 0



network 128.213.0.0 0.0.255.255 area 0



!



router bgp 100



network 203.250.13.0 mask 255.255.255.0



network 203.250.14.0 mask 255.255.255.0



neighbor 128.213.63.2 remote-as 200



neighbor 203.250.15.2 remote-as 100



neighbor 203.250.15.2 update-source loopback 0



Теперь, BGP таблица соседей на роутере «B» будет содержать следующие маршруты:

RouterB# show ip bgp



table version is 4, local router ID is 203.250.15.2



Status codes: s suppesed, d damped, h history, * valid, > best, i internal



Origin codes: i – IGP, e – EGP,? – incomplete



Network Next Hop Metric LocPrf Weight Path



*>i128.213.0.0 128.213.63.2 0 100 0 200 i



*>i192.208.10.0 128.213.63.2 100 0 200 400 500 300 i



*>i195.211.10.0 128.213.63.2 100 0 200 400 500 i



*>i200.200.10.0 128.213.63.2 100 0 200 400 i



*>i203.250.13.0 203.250.13.41 0 100 0 i



*>i203.250.14.0 203.250.13.41 0 100 0 i



*> 203.250.15.0 0.0.0.0 0 32768 i



Как видно, символ «>» появился у всех записей о маршрутах, и это означает, что BGP удовлетворен наличием достижимого next hop'а в этих записях.

Теперь IP Routing Table на роутере «B» будет выглядеть по-другому:

RouterB# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate



default



Gateway of last resort not set



203.250.13.0 255.255.255.255 is subnetted, 1 subnets



O 203.250.13.41 [110/75] via 203.250.15.1, 02:50:45, Serial0



203.250.15.0 255.255.255.252 is subnetted, 1 subnets



C 203.250.15.0 is directly connected, Serial0



O 203.250.14.0 [110/74] via 203.250.15.1, 02:40:46, Serial0



128.213.0.0 255.255.255.252 is subnetted, 1 subnets



O 128.213.63.0 [110/138] via 203.250.15.1, 00:04:47, Serial0



Пока что мы добились лишь того, что сеть 128.213.63.0 стала доступной по OSPF. Заметим, что BGP записи все еще не появились в IP routing table.

Проблема заключается в синхронизации: BGP не синхронизован с IGP, поэтому маршруты BGP не передались в IP routing table, и соответственно данные маршруты не включены в передаваемые далее BGP update.

Роутер «F» не знает о сетях 192.208.10.0, 195.211.10.0 потому что BGP маршруты все еще не redistributed into OSPF.

Выключение синхронизации


Если ввести команду конфигурации «no synchronisation» на роутере «B», и потом проверите таблицу IP маршрутизации на нем же, то выведутся следующие маршруты:

RouterB# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate



default



Gateway of last resort not set



B 200.200.10.0 [200/0] via 128.213.63.2, 00:01:07



B 195.211.10.0 [200/0] via 128.213.63.2, 00:01:07



B 192.208.10.0 [200/0] via 128.213.63.2, 00:01:07



203.250.13.0 is variably subnetted, 2 subnets, 2 masks



O 203.250.13.41 255.255.255.255



[110/75] via 203.250.15.1, 00:12:37, Serial 0



B 203.250.13.0 255.255.255.0 [200/0] via 203.250.13.41, 00:01:08



203.250.15.0 255.255.255.252 is subnetted, 1 subnets



C 203.250.15.0 255.255.255.252 is directly connected, Serial 0



O 203.250.14.0 [110/74 via 203.250.15.1, 00:12:37, Serial 0



128.213.0.0 is is variably subnetted, 2 subnets, 2 masks



B 128.213.0.0 255.255.0.0 [200/0] via 128.213.63.2, 00:01:08



O 128.213.63.0 255.255.255.252



[110/138] via 203.250.15.1, 00:12:37, Serial 0



Итак, таблица маршрутизации на первый взгляд правильная, но достичь указанные в ней сети не представляется возможным из-за того, что роутер «F», расположенный на пути к ним, не знает маршрутов к этим сетям. Это видно в результатах выполнения команды show ip route на «F»:

RouterF# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate



default



Gateway of last resort not set



203.250.13.0 255.255.255.255 is subnetted, 1 subnets



O 203.250.13.41 [110/11] via 203.250.14.1, 00:14:15



203.250.15.0 255.255.255.252 is subnetted, 1 subnets



C 203.250.15.0 is directly connected, Serial1



C 203.250.14.0 is directly connected, Ethernet0



128.213.0.0 255.255.255.252 is subnetted, 1 subnets



O 128.213.63.0 [110/74] via 203.250.14.1, 00:14:15, Ethernet0



Если пакеты, пришедшие из сети, роутеры которой обмениваются маршрутами по BGP, попадут на роутер «F», они будут утеряны. Таким образом, выключение синхронизации не решает эту проблему. Мы видим, что OSPF необходимо сделать перераспределение своих маршрутов в BGP на роутере «A»; таким образом, роутер «F» узнает о BGP маршрутах.

Ре-аннонсирование OSPF


Итак, следующая конфигурация роутера «A» модифицированна таким образом, что BGP маршруты передаются (redistributed) в OSPF:

! Router A



hostname RouterA



!



interface loopback 0



ip address 203.250.13.41 255.255.255.0



!



interface ethernet 0



ip address 203.250.14.1 255.255.255.0



!



interface serial 0



ip address 128.213.63.1 255.255.255.252



!



router ospf 10



redistribute bgp 100 metric 2000 subnets



passive-interface serial0



network 203.250.0.0 0.0.255.255 area 0



network 128.213.0.0 0.0.255.255 area 0



!



router bgp 100



network 203.250.0.0 mask 255.255.0.0



neighbor 128.213.63.2 remote-as 200



neighbor 203.250.15.2 remote-as 100



neighbor 203.250.15.2 update-source loopback 0



Теперь IP routing table будет выглядеть следующим образом:

RouterB# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default



Gateway of last resort not set



O E2 200.200.10.0 [110/2000] via 203.250.15.1, 00:00:14, Serial0



O E2 195.211.10.0 [110/2000] via 203.250.15.1, 00:00:14, Serial0



O E2 192.208.10.0 [110/2000] via 203.250.15.1, 00:00:14, Serial0



203.250.13.0 is variably subnetted, 2 subnets, 2 masks



O 203.250.13.41 255.255.255.255



[110/75] via 203.250.15.1, 00:00:15, Serial0



O E2 203.250.13.0 255.255.255.0



[110/2000] via 203.250.15.1, 00:00:15, Serial0



203.250.15.0 255.255.255.252 is subnetted, 2 subnets



C 203.250.15.8 is directly connected, Loopbackl



C 203.250.15.0 is directly connected, Serial0



O 203.250.14.0 [110/74] via 203.250.15.1, 00:00:15, Serial0



128.213.0.0 is variably subnetted, 2 subnets, 2 masks



O E2 128.213.0.0 255.255.0.0 [110/2000] via 203.250.15.1, 00:00:l5, Serial0



O 128.213.63.0 255.255.255.252



[110/138] via 203.250.15.1, 00:00:16, Serial0



Теперь записи о BGP маршрутах пропали, поскольку OSPF имеет лучшее значение Administrative Distance (110), чем IBGP (200).

Отключение синхронизации на роутере «A» означает, что роутер «A» анонсирует маршруты к сети 203.250.15.0; Это требуется потому, что роутер «A» не синхронизован с OSPF из-за mask differences. По той же самой причине, синхронизация должна быть отключена на роутере «B», чтобы этот роутер мог анонсировать сеть 203.250.13.0.

Необходимо добавить, что OSPF должен быть включен на интерфейсе Serial 1 роутера «B» и быть passive, таким образом роутер «A» узнает о next hop 192.208.10.5 через IGP.

Итак, новые конфигурации роутеров «A» и «B»:

! Router A



hostname RouterA



!



interface loopback 0



ip address 203.250.13.41 255.255.255.0



!



interface ethernet 0



ip address 203.250.14.1 255.255.255.0



!



interface serial 0



ip address 128.213.63.1 255.255.255.252



!



router ospf 10



redistribute bgp 100 metric 2000 subnets



passive-interface serial 0



network 203.250.0.0 0.0.255.255 area 0



network 128.213.0.0 0.0.255.255 area 0



!



router bgp 100



no synchronization



network 203.250.13.0 mask 255.255.255.0



network 203.250.14.0 mask 255.255.255.0



neighbor 128.213.63.2 remote-as 200



neighbor 203.250.15.2 remote-as 100



neighbor 203.250.15.2 update-source loopback 0



Конфигурация роутера «B»:

! Router B



hostname RouterB



!



interface serial 0



ip address 203.250.15.2 255.255.255.252



!



interface serial 1



ip address 192.208.10.6 255.255.255.252



!



router ospf 10



redistribute bgp 100 metric 1000 subnets



passive-interface serial 1



network 203.250.0.0 0.0.255.255 area 0



network 192.208.0.0 0.0.255.255 area 0



!



router bgp 100



network 203.250.15.0



neighbor 192.208.10.5 remote-as 300



neighbor 203.250.13.41 remote-as 100



Теперь поднимем Serial 1 на роутере «B» и получим такую таблицу BGP маршрутизации на роутере «A»:

RouterA# show ip bgp



table version is 117, local router ID is 203.250.13.41



Status codes: s suppressed, d damped, h history, * valid, > best, i – internal



Origin codes: i – IGP, e – EGP,? – incomplete



Network Next Hop Metric LocPrf Weight Path



*> 128.213.0.0 128.213.63.2 0 100 0 200 i



*>i192.208.10.0 192.208.10.5 0 100 0 300 i



*>i195.211.10.0 192.208.10.5 100 0 300 500 i



* 128.213.63.2 0 200 400 500 i



*> 203.250.13.0 0.0.0.0 0 32768 i



*> 203.250.14.0 0.0.0.0 0 32768 i



*>i203.250.15.0 203.250.15.2 0 100 0 i



Результаты выполнения команды show ip route на роутере «A»:

RouterA# show ip route



Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP



D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area



E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP



i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default



Gateway of last resort not set



192.208.10.0 is variably subnetted, 2 subnets, 2 masks



O E2 192.208.10.0 255.255.255.0



[110/1000] via 203.250.14.2, 00:41:25, Ethernet0



O 192.208.10 4 255.255.255.252



[110/138] via 203.250.14.2, 00:41:25, Ethernet0



C 203.250.13.0 is directly connected, Loopback0



203.250.15.0 is variably subnetted, 3 subnets, 3 masks



O 203.250.15.10 255.255.255.255



[110/75] via 203.250.14.2, 00:41:25, Ethernet0



O 203.250.15.0 255.255.255.252



[110/74] via 203.250.14.2, 00:41:25, Ethernet0



B 203.250.15.0 255.255.255.0 [200/0] via 203.250.15.2, 00:41:25



C 203.250.14.0 is directly connected, Ethernet0



128.213.0.0 is variably subnetted, 2 subnets, 2 masks



B 128.213.0.0 255.255.0.0 [20/0] via 128.213.63.2, 00:41:26



C 128.213.63.0 255.255.255.252 is directly connected, Serial0



B* 200.200.0.0 255.255.0.0 [20/0] via 128.213.63.2, 00:02:38



Результаты выполнения команды show ip bgp на роутере «B»:

RouterB# show ip bgp



table version is 12, local router ID is 203.250.15.2



Status codes: s suppressed, d damped, h history, * valid, > best, i – internal



Origin codes: i – IGP, e – EGP,? – incomplete



Network Next Hop Metric LocPrf Weight Path



*>i128.213.0.0 128.213.63.2 0 100 0 200 i



* 192.208.10.5 0 300 500 400 200 i



*> 195.208.10.0 192.208.10.5 0 0 300 i



*> 195.211.10.0 192.208.10.5 0 300 500 i



*>i200.200.10.0 128.213.63.2 100 0 200 400 i



*> 192.208.10.5 0 300 500 400 i



*>i203.250.13.0 203.250.13.41 0 100 0 i



*>i203.250.14.0 203.250.13.41 0 100 0 i



*> 203.250.15.0 0.0.0.0 0 32768

i


Литература


1. Олифер В.Г., Олифер Н.А., «Компьютерные сети. Принципы, технологии, протоколы: Учебник для вузов», СПб: Питер, 2007.

2. Компьютерные сети. Э. Таненбаум, – СПб: Питер, 2002.

3. Олифер В.Г., Олифер Н.А., «Введение в IP-сети». Электронный учебник. 2010-07-19 18:44 Читать похожую статью
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • Контрольная работа
  • © Помощь студентам
    Образовательные документы для студентов.